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SAFETY SYMBOLS 
Always follow safety instructions to prevent accidents and potential hazards from occurring. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Edition of October 2014 

This publication could present technical imprecision or misprints. The information here included will be 
periodically modified and updated, and all those modifications will be incorporated in later editions.  
To consult the most updated information of this product you might access through our website 
www.power-electronics.com where the latest version of this manual can be downloaded. 

 

 

 

 
     WARNING This symbol means improper operation may results in serious personal 

injury or death. 

 
  CAUTION Identifies shock hazards under certain conditions. Particular attention should 

be given because dangerous voltage may be present. Maintenance 
operation should be done by qualified personnel 

 

Identifies potential hazards under certain conditions. Read the message and 
follow the instructions carefully. 

 

Identifies shock hazards under certain conditions. Particular attention should 
be given because dangerous voltage may be present. 

http://www.power-electronics.com/
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SAFETY INSTRUCTIONS 

IMPORTANT! 
 Read this manual carefully to maximise the performance of this product and to ensure its safe 

use. 

 In this manual, safety messages are classified as follows: 

 

CAUTION 

The PowerComms tools enables to start-up the drives or inverters remotely. Do not start without 
the supervision of a qualified technician. Otherwise you may get an electric shock or damage the 
equipment. 

Before using PowerComms, read thoroughly the Software and Programming manual. Otherwise 
you may damage the equipment. 

Do not run remotely the drive or inverter with the front cover removed. Otherwise you may get an 
electric shock due to the high voltage terminals or exposure of charged capacitors. 

Do not use communication cables with damaged insulation. Otherwise you may get an electric 
shock. 

Do not subject the cables to abrasions, excessive stress, heavy loads or pinching. 
Otherwise, you may get an electric shock. 

 

WARNINGS 

RECYCLING 

 Packing of the equipments should be recycled. For this, it is necessary to separate different 
materials included (plastic, paper, cardboard, wood, ...) and deposit them on proper banks. 

 Waste products of electric and electronic devices should be selectively collected for their correct 
environmental management. 

TRIAL RUN 

 Verify all parameters before operating the drive, soft starter or inverter. Alteration of parameters 
may be required depending on application and load. 

 Always apply voltage and current signals to each terminal that are within levels indicated within 
this manual. Otherwise, damage to the drive may result. 
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1. INTRODUCTION 

PowerComms is a desktop based tool used to monitor and control Power Electronics’ solar inverter, drives 
and soft starters in the network. PowerComms can communicate with the devices using MODBUS protocol 
over Serial and TCP/IP networks.  

All the devices in the plant are organized in projects and stored as a PCP (PowerCommPlant) file format. 

The application communicates with all the connected devices at the same time. 

1.1. System Requirements 

• Intel i3 2.5GHz or higher 

• 1GB RAM (recommended 2GB RAM) 

• At least 1 GB of free hard disk space 

• Screen resolution 1024 x 768 pixels (recommended 1280 x 1024 pixels) 

• Operating system Windows XP, Vista, 7, 8 (32/64 bits). 

 

1.2. Install and Uninstall 

To install PowerComms, click on the installation file and follow the wizard setup installation guide. Click 
Next > select the installation folder > confirm installation > wait until the program is installed. 
 

To uninstall PowerComms use the Windows uninstall system to remove completely the tool and reboot 
your computer for the changes to take effect.  
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1.3. Starting PowerComms 

To access PowerComms application, the user needs to click the shortcut in the 
desktop. 

Or Click Start->programs->Power Electronics->PowerComms. 

On clicking the PowerComms application will be opened. 
 

 

 

 

1.4. PowerComms Menus 

Various functionalities of the PowerComms application are organized in the following menus: File, Edit, 
Tools, Connection, View, Window and Help. Extended icon will appear in administrator mode. 

1.4.1. File menu 

 

 



POWERCOMMS POWER ELECTRONICS 

 

10 INTRODUCTION 
   

 
All the functionalities related to creating new projects, opening existing projects, storing them after 
modification and Administrator login are grouped inside the File menu. Also options are provided to print 
pages of the projects from this menu.  

The File menu includes the following options: 

 New: This menu option is used to create a new project. Once the new project has been created, 
a new child view is automatically added to the project. 

 Open…: This menu option is used to open any previously saved project. 

 Close: This menu option is used to close the current project. 

 Save: Save the summary of the project in the existing file. 

 Save As...: Using this menu, it is possible to save the summary of the current project in xml file 
format. 

 Admin Login: This option is reserved for Power Electronics staff. 

 Recent File List: This option is used to load the recently opened projects by the user. The 
recently opened projects will be listed in the menu. 

 Exit: This option is used to exit from the PowerComms application. 

1.4.2. Edit Menu 

 

The Edit menu contains the undo, copy, cut and paste menus. 
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1.4.3. Tools Menu 

 

The Tools menu options change depending on the project status. 

Before creating/opening a project, the Tools menu contains the following option: 

 Languages: This option permits to select the software languages between Spanish, English and 
German. 

After a new project is created or opened, the Tools menu will contain options to configure the 
Connection type, Map Address, Sampling interval, Language and Updates. 

 Connection type: This option will allow the user to configure the connection type as well as 
configure the serial port communication properties. 

 Map Address: This option will allow the user to configure the Modbus TCP/IP communication 
properties. 

 Sampling Interval: This option will allow user to configure the sampling interval. 

 Updates: This option will allow seeing FTP server configuration. 

1.4.4. Connection Menu 

 
 

The Connection menu includes the following options: 

 Connect: This option is used to connect the device via serial port communication or TCP/IP 
communication. 

The device parameter view will contain information regarding the connection status on top in this 
case shows “Online Status”. 

 

 Disconnect: This option is used to discount the device. 

The connection status will be Shown as offline as shown. 
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1.4.5. View Menu 

 

 

The View menu includes the following options: 

 Toolbar: This option will allow the user to show or hide the toolbar. 

 Status Bar: This option will allow the user to show or hide the status bar. 

 Plant Window: This option will show the plant view control bar if it is hidden. 

1.4.6. Window Menu 

 

 

The Window menu includes the following options: 

 Cascade: This option will allow the user to see the device windows one above the other 
overlapping with each other. 

 Tile: This option will allow user to see the device windows without overlapping with each other. 

1.4.7. Help Menu 

 
 

The Help menu includes the following options: 

 About PowerComms: This option will display the information about PowerComms application. 



POWER ELECTRONICS POWERCOMMS 
 

INTRODUCTION 13 
 

 

1.5. Shortcut icons - Tool bar 

The tool incorporate shortcut icon bar with the following icons. 

 

 

 New: This menu option is used to create a new project. Once the new project has been created, a 
new child view is automatically added to the project. 

 Open: This menu option is used to open any previously saved project. 

 Save: Save the summary of the project in the existing file. 

 Cut, copy and paste. 

 Print 

 Help 

 Connect: This option is used to connect the device via serial port communication or TCP/IP 
communication. 

 Disconnect: This option is used to disconnect the device. 

1.6. PowerComms Exit 

To exit from the PowerComms application, either Exit from the File menu or the Exit icon in the toolbar 
can be selected. 
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2. PROJECTS MANAGEMENT 

Projects navigation tree is shown in the left part of the Power Comms window once a project is opened. 
The project structure is organized hierarchically per Plant and Devices. In each device, the IP address and 
communication port are indicated. 

2.1. Opening an Existing Project 

The existing project can be opened by selecting the Open Project in File menu or by selecting the Open 
Project icon in the toolbar, the Open Project dialog box will be displayed as shown below. 
 

 
 
The list of project names (*.pcp) that are created earlier will be displayed in the table. 

After selecting the Project name from the list and pressing Open button, the device list will be shown in 
the plant tree. 

Connect the Device and visualize the Screen information. 
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2.2. Creating a New Project 

Select the New option in the File menu or select the New Project icon in the toolbar. The new dialog box 
will be displayed as shown below: 

 

 
 

In the New Project pop up window, write the project’s name. 

On pressing Save button, the project will be created.  
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2.3. Adding Device 

Right click the plant information dialog and select the Add Device option in the popup menu. 

Enter the device information in the popup dialog and press Accept button. 

Note: depending on the Device Type, Industrial or Solar fields will be enabled. 

Device name is added in the plant view dialog. 

In our next example, we will add a SD700 drive called “SD7001”. Select the type as SD700, select 
revision as SD7_R2.3, provide TCP/IP address Information and the MODBUS Unit address. 

 

 
 

 
Note: to complete this process, it is not necessary to introduce the drive’s IP or Domain data. 

In our next example, we will add a Freesun HE inverter called “HE1”. Select the type as Freesun HE, 
select revision as HE_R2.0 and click module configuration. 
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Select the number of modules installed in the Freesun HE inverter. In this example we select 9 modules. 
 
Note: In LVT inverters select 1 module. 
 

 
 
Double click the IP field of the first module and introduce the IP or Domain address. 
 

 
 
Selecting Mega ME IP Address or Mega ME Port Number it is possible to set automatically the IP 
address or Port number respectively. System will assign successive numbers. 
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2.4. Device Options 

2.4.1. Connection Option 

Selecting the Connection option in the Tools menu, the Setting dialog box will be displayed as 
shown below: 

  

 
 

User can select between Serial Communication and TCP/IP connection types. 

To enable the serial communication port: 

 Click serial port ratio button.   Select the communication port in Port combo box.  Select the Baud rate in Baud rate combo box.  Select the Parity value in Parity combo box.  Select the Stop bit value in Stop bit Combo box. 

Click the Apply button. 
 

 
 

To enable the Modbus TCP/IP communication, click TCP/IP ratio button. 

Note: The communication type selected must be followed in all the devices of the plant. 
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2.4.2. Map Address Option 

Selecting the Address option in the Tools menu, the Unit address popup dialog will appear. This 
window provides the communications information of all the devices installed in the plant. 

 

 
 

Double click the table unit address and the configuration dialog will appear. 
 

 
 

Enter the slave address, IP address and TCP/IP port value in the Configuration dialog. 

Click the Ok button. 
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2.4.3. Sampling Interval Option 

The polling interval is the time between the start of each polling session for this system. 

The sampling interval is the frequency in which data collection takes place. 
 

The entered value must range between 50ms and 5000ms. Otherwise, an error message will appear. 
 

 

2.4.4. Language Option 

This option allows changing the application language. User can choose between Spanish, English or 
German. 
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2.4.5. Updates Option 

This option allows searching any database update file present in the FTP server. 

The system will search updates automatically every 7 days, if a new file is found it will be downloaded 
and updated. 

The details such as the IP address, port number, user name and Password must be entered to 
change the FTP server from the default settings, as it is shown in the following dialog: 

 

 
 

During the update process the status bar will display the message with the status of the file being 
downloaded as shown below: 
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2.5. Remove Device 

To remove the device from a plant, right click in the plant name. 

Select the “Remove device” option from the popup menu as shown below: 

 
 
After selecting this option a message will appear and if it is accepted, the device will be removed from 
the plant and its corresponding view closed. 
 
If the device is Online, this option is disabled. 
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2.6. Edit Device  

To edit the device information, right click in the device name. 

Select the Edit device option from the popup menu. 

 
 
Edit device information popup dialog will appear. 
 

 
 
Modify the device information and click the Accept button. 
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2.7. Download 

The option is used to load all the parameters from a Device Configuration File (.dcf file) to the Device. 

To download the device configuration, right click in the device name. Select the “Download” option from 

the popup menu as shown below. 

 

Note: this option is enabled while the device is connected. 

Then, another dialog called “Load” appears. 
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Select the Normal Load option. 
 

Click on the Select button. The following popup dialog appears to select the location of the device 

configuration file (*.dcf) in the system. 

 

Click on the button Ok. 

The Load action will be enabled once the button Load is clicked. At this time, the parameters start to be 

written into the device. 

If any parameters are failed to be written to device, check the following reasons and try again: 

a) Off to modify parameters.  
b) Pump mode variables; drive running in Standard mode.  
c) Protection locked variables. 
d) Communication failure.  

The list will be generated in the table as shown below: 
 

 
 

The generated list can be saved in the system by clicking on the button Save Log. Provide the location 

and the file name of the log file in the Popup dialog to export the list into an Excel File.
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2.7.1. HE Download Type Options  

There are 2 download options for Freesun HE devices: 

1. Normal Load: this download type is similar to the default download option, which will load all 

the parameters from the .dcf file to the device. 

2. Production Mode Load: this download type is used during the production test, where only 

G1 and G8.5 parameters will be loaded into the Device. Reserved for Power Electronics staff. 

2.7.2. SD700 Download Type Options 

There are 3 download options for the SD700 device: 

1. Legacy Download: this download type is similar to the default download option, which will 

load all the parameters from the .dcf file to the device. 

2. Legacy with Priority Download: this download type will load all parameters except  

 Digital Inputs. 

 Limit Variables. 

3. Special Download: this Download type will send a special request to the drive called "write 

request" and the drive will approve the request only if any of the following conditions are 

satisfied: 

1) The drive is not currently downloading any other parameters. 

2) The drive is not in RUN state or commissioning mode. 

3) The special download command is enabled for that version. Otherwise, an error 

message will appear. 

4) The selected directory is found. 

5) The path is valid. 

Once the Download is complete another special request will be sent to confirm the download 

has been completed and to stop the process, to the Device. 
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2.8. Save DCF 

This option is used to store the device configuration into the system as a .dcf file. It is necessary to select 

the complete software in the visualization window that appears after clicking in a device. 

 

To access this option, right click on the device name. 

Click on the Save DCF option as shown below: 

 

Note: this option is enabled while the device is connected. 

This action will open a popup dialog box to save the parameters. 

 



POWERCOMMS POWER ELECTRONICS 

 

28 PROJECTS MANAGEMENT 
   

 

Clicking on Select, will open a popup dialog to enter the location and name of the .dcf file to be saved: 

 

Click on the Save DCF button to save the file. 

The list can also be stored in the system as a log file by clicking on the Save Log button. 

2.9. Header  

This option will let the user to enter motor and commissioning details. Motor fields will be disabled for 

solar inverters. To access this option, right click on the device. 

 

These details will be saved in the XLS file header when the device configuration information is copied to 

the system. 
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The dialog will contain the following edit fields to be completed by the user: 

 
 

Note: Date is taken from the system. 

2.10. Save XLS  

This option is used to save the device configuration in a .xls file. It is necessary to select the complete 

software or a parameter group in the visualization window that appears after clicking in a device. To 

access to this option, right click on the device name.  

 

 

 

 

 

 

 

 

Note: this option is enabled while the device is connected. 

Once the option is selected, another popup dialog asking for the .xls file saving location appears. 
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Click on the save button and the file will be uploaded and saved in the system. 

2.11. Close the plant 

To close the plant, right click in the plant name. Select the “Close Plant” option from the popup menu as 
shown below. 
 

 
 
The plant tree view will be closed as the views corresponding to the plant. 
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3. VISUALIZATION AND CONFIGURATION 

3.1. Connection and Disconnection 

To access to the visualization and configuration screens, it is necessary to connect the devices. In the 
navigation tree, there are four connection statuses shown by icons as follows. 

 
Icon Description 

 
Connecting 

 
Connected 

 
Disconnected 

 
Connection error. (Verify IP address) 

3.1.1. Connecting the Device 

Select the Connect option from the Connection menu, select the Connect icon in the toolbar, or 
right click in the device or Plant name and select the “Connect” option in the popup menu.  

 

 
 

 
Verify that the status connection icon has been changed to connected. 
 
The device status will be updated in the parameters view. 

 

 

3.1.2. Disconnecting the Device 

Select the Disconnect option from the Connection menu, select the Disconnect icon in the toolbar, 
or right click in the device or Plant name and select the “Disconnect” option in the popup menu. 
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Verify that the status connection icon has been changed to disconnected. 
 
The device status will be updated in the parameter view as follows: 

 

 

3.2. Device Information Screen 

To View the device information screen, double click the device name in the plant tree view. 

If the Device version database is available, a new window will appear with the following options: 

1. Parameters View. 
2. Data logger View. 
3. Graphical View. 

Furthermore, if the Device type is Freesun HE, the following options will be added: 

4. SS Configuration. 
5. SS Visualization. 
6. Module SS Visualization. 

Furthermore, if the Device type is SD700FR, the following options will be added: 

4. Diagnostic Status. 

Furthermore, if the Device type is XMV660, the following options will be added: 

4. Cell Status. 

The following tabs contain an example of parameters list in a Freesun HE inverter. 
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If the device version is not available, the version selection popup dialog will appear. Select one database 
from the available list. 
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3.3. Parameter View 

After double clicking the device name in the plant tree view, the first window that appears allows user to 
visualize and modify the configuration and visualization parameters. 

The information contained in this screen includes the Screen name, the value, the value’s unit, the 
parameter R/W type, and the maximum, minimum and default values. 

To visualize parameters and set parameters at real time, the device must be connected. 

3.3.1. Modify the screen value 

To modify the screen value, double click the value field in the device parameters table. 

Then, a new popup dialog will appear. 
 

 
 

Enter the new value in the Set Value field. 

Click the Ok button.  
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3.4. Data Logger and Graph View 

The Data Logger View tab is where the device data can be collected and stored following the specified 
polling interval in a table. 

The Graph View tab is where the device data is collected and stored following the specified polling 
interval in a graphic. 

The collected data can be exported from the application or imported to the application. 
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3.4.1. Configure the Datalogger parameter list and sample interval time 

To configure the Datalogger (DL) parameter list, click the “configure” button of the DL tab or of the 
Graphic tab.  

The DL configuration dialog will appear as follows: 
 

To select the variable, press the “ ” button in the DL configuration dialog. 

Select the variable from the popup tree dialog shown below: 
 

 
Enter the sample interval value in edit box. 

Press the ok button. 

Enter the range in Minimum and Maximum value edit box. 
 
Note: the clear button allows deleting the data introduced in its corresponding line. 
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3.4.2. Start the Data logger 

To start the data logger, click the start button in the DL tab or the Graphic tab. 

If the device is in online status, the selected variables will be logged. 

 The values of the logged variables are shown in a table format in the data logger view. 

 The values of the logged variables are shown in a line graphic format in the graphic view.  

The following figures are two examples of the two tabs. 

If the device is not in online status, the data logger will not start.  
 

 

 



POWERCOMMS POWER ELECTRONICS 

 

38 VISUALIZATION AND CONFIGURATION 
   

 

3.4.3. Stop the Data logger 

To stop the data logger, click the stop button in the DL tab or the Graphic tab. 

Once data logging is stopped, the x-axis time interval values are updated in the graph. 
 

 
 
The graph view will show the last 31 samples values in a line graphic. 

If the number of log samples is greater than 31, the track bar and the Zoom (-) buttons are enabled in the 
graph view. 

To visualize the previous samples, move the track bar in the graphic view. The line graph will be updated 
depending on the track bar position. 

After every Zoom (-) button click, the number of viewed samples is increased by 10. 

If the number of viewed samples reaches 151, the Zoom (-) button is disabled. 

After every Zoom (+) button click, the number of viewed samples is decreased by 10. 

If the number of viewed samples reaches 31, the Zoom (+) button is disabled. 
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3.4.4. Export the DL samples 

The logged data can be saved into the system using the export option. 

There are 2 ways to perform this: 

1. Export in Configuration file (I.e PowerComms Log File format (.plf)). 

Enter the file name in the file save dialog. 

Press the Save button. 
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2. Export in Microsoft Excel file format (.xls). 

Enter the file name in the file save dialog. 

Press the Save button. 
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3.4.5. Import the DL Samples 

To import the datalogger samples from a file: 

 Click the Import button in DL View tab or Graphic View tab. 

 Select the file (xxx.plf) from the dialog.  

 Press the Ok button. 

The values of the logged variables are shown in a table format in the datalogger view. 
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3.4.6. Clear DL Samples 

To clear the data logger samples from the table and graph. 

Click the Clear button in the DL View tab or the Graphic View tab. 
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3.5. SS Configuration View 

This tab will be visible for HE inverters. The tab will be available only if the String Supervisor (SS) is 

connected to the inverter. 

The string supervisor monitors the solar panel strings statuses to detect quickly the incorrect operation of 

a part of the photovoltaic field. 

By default, the first SS configuration information will be displayed in the SS Configuration view. 

If the SS configuration tab is currently selected, the SS configuration values will be read from the 

inverter. Otherwise, the SS configuration information will not be read. 

The SS configuration values are read only when the SS configuration tab is selected. 
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3.6. SS Visualization View 

This tab is visible only for HE inverters. The tab will be enabled only if the String Supervisor (SS) is 

connected to the inverter. 

By default, the first SS Visualization information will be displayed in the SS Visualization view. 

If the SS Visualization tab is currently selected, the SS Visualization values will be read from the inverter. 

Otherwise, the SS Visualization information will not be read. 

The SS Visualization values are read only when the SS Visualization tab is selected. 
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3.7. Module SS Visualization View 

This tab is visible only for HE inverters. The tab will be enabled only if the String Supervisor (SS) is 

connected to the Inverter. 

The tab will have information about the SS Visualization parameters of all the modules present in the HE 

inverter. 

By default, the first SS Visualization information will be displayed in the SS Visualization view. 

If the SS Visualization tab is currently selected, the SS Visualization values will be read from the inverter. 

Otherwise, the SS Visualization information will not be read. 

The SS Visualization values are read only when the SS Visualization tab is selected. 

 

 



POWERCOMMS POWER ELECTRONICS 

 

46 VISUALIZATION AND CONFIGURATION 
   

 

3.8. HE Plant View 

The window displayed when the device type is Freesun HE (Module SS Visualization View) is part of 

Module SS Visualization View.  

Click the Plant name. The Plant data of all the Freesun HE installed will be displayed.  

It contains information about SV.15.1 group. 

 

 
 

Note: this option is enabled while the device is connected. 
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3.9. HE Inverter View 

The window displayed when the device type is FreeSun HE (Module SS Visualization View) is part of 

Module SS Visualization View.  

Click the HE inverter name. The HE inverter view will be displayed.  

It contains information about SV.15.1 group, SI Master Info menu screen value is the same in all the 

modules present in the HE Inverter. 

 

 
 

Note: this option is enabled while the device is connected. 
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3.10. Diagnostic Status 

The diagnostic status tab is only available with a SD700FR drive connected. The tab lists out all the 

diagnostic data that has been generated when the event is raised. 
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3.11. Cell Status 

The cell status tab is only available with a XMV660 drive connected. The screen will be different 
depending on the number of cells per phase of the XMV660 drive. The Cell Status view will be shown in 
the below tab. 
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